Skip to content


Unity Version

Supported Unity version range: 2019.4 - 2022.3. Only latest patches of the associated LTS streams ↗ in the range are supported. Alpha, beta and non-LTS releases (eg 2021.1 or 2022.2) are not supported. They may work, but we won't be able to provide any support for using Naninovel with them. Recommended Unity version is 2019.4.40 ↗.


It's not uncommon for Unity to introduce regressions even in LTS patches (let alone major releases), hence we recommend 2019.4.40, which is in its final state and doesn't have any known bugs associated with typical VN development. 2020 and 2021 are known to suffer from stability and performance regressions; in case you need a modern Unity version — use 2022.3.

Compatibility issues with future Unity releases (once they reach LTS status) will be addressed in the next Naninovel releases. Compatible Unity versions for past Naninovel releases are specified in the change logs ↗.

UPM Packages

Only verified package versions are supported. When installing or updating a package via Unity's package manager, make sure it has a "verified" label for the Unity version you're currently using.



All the engine features are implemented using cross-platform APIs and are expected to be compatible with all the platforms Unity can target.

The following platforms were tested for compatibility and are officially supported by us:

  • Standalone: Windows, Mac, Linux
  • Mobiles: iOS, Android
  • Web: WebGL
  • Consoles: Nintendo Switch


While Unity allows building for numerous other platforms (PlayStation, Xbox, Stadia, etc), some features (eg, save system) may not work out of the box, as access to the platform-specific SDKs is restricted for registered developers only. We don't have the access to such SDKs and are not able to provide support for platforms outside of the list above. Find more information about developing for game consoles in the article ↗.

Enter Play Mode

Naninovel supports disabling both Reload Domain and Reload Scene options under "Enter Play Mode Settings" category of the project settings. Disabling the options will make entering play mode take less time, especially in large projects.


Render Pipelines

While it's possible to use Nanionvel with Unity's scriptable render pipelines ↗ (both URP and HDRP), some built-in features may not work out of the box and we won't be able to provide any support in such cases; see render pipelines guide for more information.


Legacy (uGUI) text component is not supported by any of the built-in UIs or associated APIs; TextMesh Pro ↗ is used by default.

Managed Stripping

"Medium" and "High" managed bytecode stripping ↗ profiles are not supported. Either disable the stripping or use the "Low" profile (selected by default).


At least "Explicitly Thrown Exceptions Only" level is required for Enable Exceptions option in "Publishing Settings" (selected by default). The setting is only applicable for WebGl builds ↗. "None" level is not supported.